App acting incredibly inconsistently for the past couple days
  • I have had trouble loading pictures and even thumbnails consistently on this app, which seems to be solely on the app's part because all the boards I searched in seem to be working completely fine on my pc(gelbooru, danbooru). At first images that weren't already cached and had 2 size options would just not load at all, but then I made a weird fix by changing from normal size to original. I then changed options to always load original which made the app function fine for searches, but sometimes it would still cough and rend me unable to load images for a while, which seemed only solvable by waiting extensively.

    As for thumbnails, old uncached favorites won't have them load anymore at all, tapping the image and waiting a longer time than normal (the load bar would not show up for about 30 secs) would load the image, but the thumbnail would still not be there after backing out.

    I have been using 1.38 of the Android app and updated to 1.39 yesterday in which the problem still persisted. I am updated to Android 7.1.2

    Edit: I just deleted my cache to see if that solved anything, the app is still VERY inconsistent. Some searches seemed to stop loading thumbnails after a certain point, and would not load any of the images at all for a long time, once again solved somehow by waiting and making another search. The favorites section just stopped loading thumbnails after the 84th picture and only images toward the start would load in a reasonable amount of time. It all just seems to be working very slowly. Restarting the app would not solve this
  • 14 Comments Ordenar por
  • The exact same problem has been happening to me as well, I am on version 1.39 of the Android app as well and am on Android version 6.0.1
  • I have same problem, tried both 1.38 and 1.39 versions, Android 7.1.2, can't load any picture where original image's size is different from normal image, can't load any of my favourites.
    Also, my settings stay somehow even if i delete them manually and then reinstall the app, they come back, even my lock screen and favourites.
  • Which server are you using? Or are you using the default one?

  • I'm using Gelbooru, same settings I used for year and a half now, everything worked perfectly before.
  • Wait, I just noticed the problem, but only on the original Gelbooru. It looks like one of the assets mirrors is not responding.

    Gelbooru's API balance the charge between several file mirrors. The mirror is assigned at random when you search. This is why sometimes it works, and sometimes it won't. And sometimes the original and normal images point to different mirrors too.

    I'm sure this is a temporal issue, there is nothing that needs to be done on the App. But if the problem persist I'll report it on their forum. I believe something like this has happened before, just give it a few days.

    To confirm the above, you can try this:

    -When you see a post that won't load, open the info panel.
    -Long tap on the normal/original image row (do it on the version you are seeing).
    -Select any browser from the list of apps.
    -The url should say assets2.gelbooru.com (let me know if is different).

    I couldn't reproduce the issue using Danbooru. If you are sure it happened too on Danbooru, do the same as above and paste the URL here.

    @PhillipJeffries as far I know Android is supposed to be deleting everything when uninstalling. Perhaps Android is backing up the Application Data on a cloud service, and then restoring after reinstalling, but I'm not sure. Anyway, we cannot run custom code while uninstalling.
  • Mine goes straight to gelbooru.com to the image, no assets2. Loads perfectly fine on the phone browser but not on the app

    Example: https://gelbooru.com/images/b3/fe/b3fe7ea8ebd84f798eff75b105616721.jpg
  • All pictures in my favourites have urls that say "assets.gelbooru.com", not "assets2", and they won't load, even in browser. In "search" all pictures have urls "simg4.gelbooru.com" and they load in browser, but not in the app. Picture will load in browser when I change "assets" to "simg4".
  • @FapAttak @PhillipJeffries thanks. I'll take a look again, it sounds like it could be something else.
  • I seem to be having this issue as well. I am using the Gelbooru server and tried using the default server as well. No images load at all. The browse all tab doesn't load anything same with favorites. I checked the urls and they all seem to be direct image links to Gelbooru, just like FapAttak.

    Edit: I was also using Version 1.3.8 and had recently updated to 1.3.9 if that helps.

    Edit #2: Default (danbooru 2) server is sort of random. Sometimes it doesnt load, sometimes it partially loads low quality images, sometimes it works.
  • Any update on the matter? Not being able to use this app properly sucks so much when it's such a great one I've been using for so many years! :(
  • We are still looking into it, we weren't able to reproduce on our test devices.

    I may have found the problem, but I'm not entirely sure.

    By any chance, does any of you have configured your gelbooru server as http://gelbooru.com or http://www.gelbooru.com ? With "http" instead of "https"?

    If this is the case, could you try adding or editing the server with "https://gelbooru.com"? You need to type the "https://" part at the beginning.

    Gelbooru is now redirecting from http to https. I'm sure it was possible to add the site with "http" just a few weeks ago, but now you get an "invalid credentials" error when trying to save the server.

    I forced the App to use http and now every image fails to load. This is similar to @Totallyirrelevant's description, but it doesn't fit exactly with @FapAttak's description, were some post will load and others don't. Maybe the transition wasn't immediate, but I can't tell.

  • I was using http beforehand which worked before these problems, but switching to https made it work just as fast as normal! Sadly the thumbnails of my old favorites still no longer work, but that must be because of them being from the http server.
  • @FapAttak thank you for the fast response, is really helpful.

    The favorites are saved with the info on memory at the moment you press the button. Favorites don't really have a relationship with the server, so changing one won't affect the other. In this case, is going to be an issue, since the current metadata of your favorites may be obsolete.

    On iOS we included a "Reload" option to the viewer. It appears only when a post is among your favorites, and it allows you to reload the metadata of the visible post. This action updates tags, file urls, notes, etc. Android doesn't have it yet, but we are going to try to add it on the next update. This way you may recover your favorites, without deleting and adding them again.

    We are not including a "Reload All" since each favorite represents a call to the server, and it may be too heavy, which we want to avoid. Also, is not that easy to make.

    This still doesn't explain yet the problem on danbooru, and I don't think they are really related. The default server on Android is using http (https on iOS), but you can configure your own as https. I tried to reproduce the problem using the default and a custom server and it just works. Maybe this is just an network issue, I have seen it happening that sometimes the download just stops, but is very rare.




  • Thanks for the fix, danbooru may have just been a temporary issue, as it works fine. I'm looking forward for the next update so I can hopefully grab my favorites back haha!

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!