Loading wheel and thumbnail flicker when loading certain images iOS.
  • I have the latest version of the app and iOS version 11.2.6, and on certain posts (mainly on danbooru.donmai.us) the image won't load and the status wheel/thumbnail flicker.

    This is with non-animated image formats such as jpg, png, etc. This issue doesn't seem to pop up on gelbooru based servers for whatever reason. It seems like the app gets stuck in a loop, and returning to the search results while trying again nets the same result. It'll load other images, but not that particular one that triggers the bug. It also seems to happen at random; the image source server (imgur, tumblr, etc.) doesn't seem to matter.

    I tried clearing cache and reinstalling the app, and the bug persists. It seems to leave a runaway thread too, as once the bug is triggered the app's battery usage skyrockets.
  • 2 Comments Ordenar por
  • I was able to reproduce the problem as well. Is pretty random, it could be on old or new posts.

    We are already looking for a solution, hopefully won’t take long.

    Thanks for reporting it.
  • Well, this stopped happening a couple of days after my previous reply. I haven't been able to reproduce it ever since.

    I noticed the problematic post were hosted on hijiribe rather than on danbooru, so I guess the problem was related to that. Sadly I couldn't catch the problem while debugging, so I can't tell for sure exactly what was the issue.

    In theory, if App can't get the file, it should stop after the second try, so the endless loop of request shouldn't be happening.

    If anybody knows a particular query that returns post with this issue, please let me know.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!